Bonsai forum

TOPIC:

Not quite lead drop? 3 months 2 weeks ago #69308

  • RootedGrowth
  • Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 15
  • Thanks received: 0
I’m not sure what’s going on with my maples. I have not found any critters but all of the leaves on this tree are in tatters. This tree I plucked from a seedling last August. I have not done anything to it besides the wiring it has been sitting in this pot ever since. I did give all of my trees a feeling about three weeks ago 75% strength miracle grow water soluble mix.

Please Log in or Create an account to join the conversation.

Not quite lead drop? 3 months 2 weeks ago #69309

  • RootedGrowth
  • Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 15
  • Thanks received: 0
Seems like the pictures did t post

This message has attachments images.
Please log in or register to see it.

Please Log in or Create an account to join the conversation.

Not quite lead drop? 3 months 2 weeks ago #69311

  • Ivan Mann
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 1363
  • Thanks received: 472
There is a lot of something eating the leaves. Look under the leaves. If you don't see anything, get some systemic bug killer. I would suspect caterpillar so insecticide might be the answer.

Please Log in or Create an account to join the conversation.

Not quite lead drop? 3 months 2 weeks ago #69312

  • lucR
  • Away
  • Platinum Member
  • Platinum Member
  • Posts: 1347
  • Thanks received: 448
I have been searching for years to find something on one of my trees, untill i accidently found them hiding under the rim of the pot. They migrated each night from under there, feed on the leaves and would go back to hide in the morning. Caterpillars indeed
The following user(s) said Thank You: Ivan Mann

Please Log in or Create an account to join the conversation.

  • Page:
  • 1